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Introduction 

 
Admin Report Kit for SharePoint 2007 (ARKSP) is a powerful configuration and usage 
reporting tool for Microsoft Office SharePoint Server 2007 and Microsoft Windows SharePoint 
Services 3.0. ARKSP presents information across web applications, site collection, sites and lists 
in SharePoint in simple report formats.  
 
ARKSP collects configuration information about Web Applications, Site Collection, Sites and its 
sub-sites, List Configuration and List Details etc. and presents them in a useful format for 
SharePoint Administrators and Users. 
 
The functional benefits of using ARK for SharePoint 2007 include:  
 

 Reports are conveniently organized according to SharePoint information hierarchy. 
 

 View information about how certain features in SharePoint are being used by users 
 

 Schedule report generation process to off-peak hours 
 

 Filter unwanted fields and select the desired fields to report. 
 

 Customize reports for display, print, export and publish. 
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1) ARK for SharePoint 2007 Installation Requirements 

 
 
Hardware: Intel Pentium processor, 512 MB of RAM, 4 MB disk space to install DocKIT 
 
Operating System: Windows 2003 (or) Windows Server 2008 with .NET Framework 3.0 or 
higher with the latest service packs. 
  
Software: Microsoft Office SharePoint Server 2007 (or) Windows SharePoint Services 3.0 (64-bit 
/ 32-bit) with latest Service Pack 
  
Database: Microsoft SQL Server 2005 (Enterprise / Standard / Developer / Express edition) 
running in local / remote computer 
 
Microsoft Data Access Components (MDAC) v2.8 only 
 
Note: ARKSP must be installed in the web front-end server / application server in the 
SharePoint farm. 
 
 
Installation Instructions Once you download the software, install applications packages (.msi) 
depending on your import requirements. The simple setup wizard will guide you through the 
installation process. 
 

 ARKSP2007_x86_v3.x.msi in order to install ARK for SharePoint 2007 application in 
Windows 2003 ï 32 bit environment. You can use this setup file to install ARKSP 
application in the Front-end Web Server / Windows SharePoint Services 3.0 installed 
server. 

  

 ARKSP2007_x64_v3.x.msi in order to install ARK for SharePoint 2007 application in 
Windows 2003 ï 64 bit environment. You can use this setup file to install ARKSP 
application in the Front-end Web Server / Windows SharePoint Services 3.0 installed 
server. 
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2) ARK for SharePoint 2007 Installation Option 

 
 
ARK for SharePoint 2007 can be installed either from the installation file available on your hard 
disk, or you can download the latest installation file from website (www.vyapin.com). 
 
Before you start installing ARKSP, we strongly recommend that you visit the website to check for 
a new installation file. This way you can be sure to install the latest available version of ARK for 
SharePoint 2007. 
 
ARK for SharePoint 2007 (ARKSP) product's evaluation version has the 15-day limit. 
 
The sales number can be found on << http://www.vyapin.com/contactus.htm >>. If you purchased 
your copy of ARKSP on-line, your license key will have been delivered to you via e-mail. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

http://www.vyapin.com/
http://www.vyapin.com/contactus.htm
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3) ARKSP Installation Process  

 
 

To install ARK for SharePoint 2007 on your computer, you need to get the latest installation file. 

We recommended getting the latest installation file online. You can download the file from the 

website (http://www.vyapin.com) / Downloads section. 

 

Once you have downloaded and saved the installation file on your hard disk, you can launch the 

installation process. The installation is a sequence of dialog windows with a brief description of 

what do at each step. In the following, we offer an explanation for each dialog window: 

 

3.1. Installation Launch 

 
 

 
 
 
The installation process starts with the ARKSP for SharePoint 2007 Logo.  
 
Press the {Next} button to continue the installation process. 

 
 

http://www.vyapin.com/
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3.2. Select Installation Type 

 
 

 
 
 
If you have older version of ARK for SharePoint 2007, it prompts whether you need to repair ARK 
for SharePoint 2007 or presently remove the application from the hard disk where ARK for 
SharePoint 2007 was installed.  
 
It is requested to remove the installed version from the hard disk and install new version 
(downloaded version). 
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3.3. Welcome Screen 

 
 

 
 
 
The Welcome screen will be displayed, now press next button to proceed. You will be prompt to 
the readme file. 
 
Press the {Next} button to continue the installation process. 
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3.4. Readme Screen 

 
 

 
 
 
Press the {Next} button to continue the installation process. 
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3.5. License Agreement 

 
 
The License Agreement dialog provides the full wording of the ARKSP license agreement. Please 
read it carefully and confirm that you have read, understood and accept the agreement by 
pressing the I Agree button. If you do not agree with the license agreement press the I Do Not 
Agree button, and the installation process will be terminated immediately. 

 

 
 
Having confirmed the license agreement you will be redirected to the location where ARKSP for 
SharePoint 2007 to be installation.  

 
 
Press the {Next} button to continue the installation process. 
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3.6. Installation - Destination Folder 

 
 

 
 
 
The Destination folder dialog allows you to specify the location where ARKSP should be installed. 
By default, ARKSP will be installed to the program files folder located on rive C:\. If you want to 
change this location, use the Browse button to display the drive structure, and select the 
respective folder. Press the Next button to confirm. 

 
Press the {Next} button to continue the installation process. 
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3.7. Installation Progress 

 
 

 
 
ARKSP for SharePoint 2007 will now be installed in your Hard Disk. 
 
Once the installation is successfully completed you will be prompt to the next screen. 
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3.8. Installation Complete 

 
 
The Installation Complete dialog is the last step of the ARK for SharePoint 2007 installation 
process. 
 
ARK for SharePoint 2007 is now installed on your computer and fully functional.  
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3.9. Launching ARK for SharePoint 2007 

 
Having finished the ARK for SharePoint 2007 installation, ARK for SharePoint 2007 is accessible 
from the menu Start / All Programs / ARK for SharePoint 2007 / ARKSP 

 

 
 
 
Once you select ARKSP from Programs you will be prompt with the screen below. The screen 
that you view shows that the application is under evaluation period and it also highlights the 
number of days that you can use this application. 
 

 Note: ARK for SharePoint 2007 (ARKSP) product's evaluation version has the 15-day limit. 
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3.10. Evaluation Screen (Information) 

 

 

 
 
 
Press the Start button to continue. 
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3.11. How to uninstall ARKSP? 

 
When you create Power Report tasks in ARKSP, the application creates Windows Scheduled 
Tasks (to run the Power Report tasks at the specified time interval) where ARKSP is installed. 
While running the Quick Reports or Power Report task, ARKSP creates ARKSP Settings folder to 
store the application settings, Log folder to store error log file, Export folder for exported reports, 
Power Reports folder for Power Reports task related information, SQL Server database for data 
storage. 
 
When you uninstall ARKSP through Control Panel - Add / Remove Programs applet, Windows 
Installer program will remove only the application files from your machine. But, the application 
related files created by ARKSP remain in the computer. In order to remove ARKSP worker files 
completely, the uninstall wizard provides a set of cleanup options to perform the cleanup 
operation based your selection. 
 
Use this wizard to clean up the files that are created by Admin Report Kit for SharePoint 2007 
application selectively and uninstall ARKSP completely from the machine.  
 
Launch the uninstall wizard by clicking Start -> Programs -> Admin Report Kit  for SharePoint 
2007 -> ARKSP Uninstall Wizard. 
 
The ARKSP Uninstall Wizard dialog will be shown as below: 
 

1.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Click Next to proceed. 
 
Select required cleanup options as shown below: 
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2.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Click Next to proceed. 
 
Confirm the cleanup and/or uninstall process. 
 

3.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Click Finish to run cleanup and/or uninstall process. Click Cancel to close the wizard. 
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Once the file cleanup process is complete, the uninstall wizard will automatically run Windows 
Installer program to remove ARKSP application from the machine, if you have selected the 
cleanup option Uninstall ARKSP application in the wizard. 
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4) ARKSP User Interface 

4.1. How to get started? 

 
Before beginning to use ARK for SharePoint 2007 to generate reports, you must enable a few 
settings and configure the application database as outlined below: 
 
SharePoint Settings: 
 
1. SharePoint user permissions: ARKSP uses the currently logged on user account while 

running Quick Reports (under interactive mode) and uses 'Run As' account while running 
Power Reports task (run as a scheduled task or using Run Now option) to generate the 
corresponding reports. 
 

      ARKSP requires the above mentioned user account to be: 
 
a) Member of administrators group in SharePoint Server and Database Server  

[This will be useful if you are generating reports for multiple SharePoint sites residing in 
different web applications] 

OR 
b) Application pool user account of a web application  

[This will be useful if you are generating reports for a single web application hosting the 
SharePoint site] 

OR 
c)   Farm Administrators group of the SharePoint farm 
 
Recommendation: It may be of help to use a domain admin account who is member of 
administrators group in SharePoint and the SQL Servers to generate the SharePoint reports for 
all web applications seamlessly. 
 
2. Audit Settings - ARKSP provides Audit Reports across Site Collections and Lists available 

in SharePoint web application. You have to enable audit settings in MOSS / WSS to view 
these reports in ARKSP. 

 
3. Usage Analysis Settings - ARKSP presents usage information about various SharePoint 

objects namely, web application, site and list item as recorded in the STS / IIS log files. In 
order to generate these reports successfully, you need to enable STS / IIS logging in 
SharePoint and IIS respectively.  

 

SQL Server Settings 

ARKSP uses SQL Server database for its data storage to generate SharePoint reports. ARKSP 
requires an SQL Server running SQL Server 2005 (Enterprise / Standard / Express editions) to 
connect and create a database. ARKSP will connect to the specified SQL Server based on 
authentication mode and user credential to manage its own application databases. You have to 
specify the suitable SQL Server settings in ARKSP to view these reports in ARKSP. 

ARKSP uses the USER ACCOUNT based on the SQL authentication mode set in SQL Server 
settings in ARKSP to create database and store report data. 

The USER ACCOUNT denotes the currently logged on user account while running Quick Reports 
(under interactive mode) and denotes the óRun Asô account while running Power Reports task 
(run as a scheduled task or using Run Now option). You can also use an exclusive SQL user 
account to create and manage its own application database. Please not that ARKSP requires the 
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USER ACCOUNT to have sufficient privilege to create, add and delete database in the SQL 
server. 
 
ARKSP Features 
 
ARKSP features are broadly classified as follows: 
 

A. Quick Reports ï Provides a set of SharePoint configuration, permissions, usage and 
audit reports for web application, site collection, site and list and their items. This task 
option is ideally suited for quick glance of the current SharePoint information.  
  

B. Custom Reports ï Facilitates customizing ARKSPôs Quick Reports output by selecting 
the desired fields and their field order. 
 

C. Power Reports ï The Power Reports uses óTaskô based approach that allows you to 
select multiple reports with customized (sub-set) fields, define report criteria and 
schedule export of reports periodically. This feature will enable the user to export multiple 
reports for several sites / lists in SharePoint at periodic intervals. 
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4.2. How to configure SQL Server Settings 

 

 
ARKSP uses SQL Server database for its data storage to generate SharePoint reports. ARKSP 
requires an SQL Server running SQL Server 2005 (Enterprise / Standard / Express editions) to 
connect and crate a database. ARKSP will connect to the specified SQL Server based on 
authentication mode and user credential to manage its own application databases. 

 
ARKSP will prompt for the SQL settings (Server name, authentication mode, user name and 
password) when Quick Reports / Power Reports / Custom Reports feature is launched for the 
very first time. SQL Server Settings dialog appears as shown below : 
 

 

 

Subsequently, ARKSP maintains its application settings (SQL settings, E-mail settings, Power 
Reports tasks and history) in a set of XML files created in the application installation folder. 

You can also specify SQL Server settings to use by clicking Tools -> SQL Server settings menu 
in the ARKSP main application window. 

How ARKSP manages database in SQL Server using the given SQL settings: 

 
User Authentication: 

To connect to SQL Server, ARKSP uses the relevant user accounts based on the authentication 
mode as listed below:  

A.  Windows Authentication: 

In this method, ARKSP uses the currently logged on user account while running Quick Reports 
(under interactive mode) and uses 'Run As' account while running Power Reports task (run as a 
scheduled task or using Run Now option) to authenticate the user in SQL Server.  
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B. SQL Authentication: 

In this method, ARKSP uses the specified SQL user account and password for running Quick 
Reports and Power Reports tasks. ARKSP stores the SQL user name and password as a user 
profile in 'Stored User Names and Passwords' applet for its usage.  

      Read Profile Manager for more details. 

 

 Note: ARKSP expects the user account to have sufficient privileges to create, add to and 
delete database in the SQL server. 

 

 
Database creation  

ARKSP creates databases in SQL Server as per the information outlined below: 

a. Quick Reports  

Quick Reports feature in ARKSP creates a single application database in the default data 
storage location used by the SQL Server during application launch. ARKSP uses the 
following naming convention for its Quick Reports database: 

ARKSPDATA-<SERVER NAME> 
  
For example: ARKSP creates 'ARKSPDATA-RD61' with data ('ARKSPData-RD61.mdf') and 
log ('ARKSPData-RD61_log.LDF') files stored in the default SQL data folder in the SQL 
server (C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data). 

b. Power Reports  

Power Reports feature in ARKSP creates a database in the default data storage location 
used by the SQL Server for every run instance of the Power Reports (scheduled) task, 
either at the scheduled time interval or when using Run Now option. ARKSP uses the 
following name convention for its Power Reports database: 

For Scheduled Run: ARKSPDATA-<SERVER NAME>-<TASK NAME>-
<yyyymmddhhmmss>  
 

For Run Now: ARKSPDATA-<SERVER NAME>-<TASK NAME>-RUNNOW-
<yyyymmddhhmmss> 
 
For example, ARKSP creates  
 
Scheduled Run: 'ARKSPDATA-RD61-ListDetails-20081125120409' with data 
('ARKSPDATA-RD61-ListDetails-20081125120409.mdf') and log ('ARKSPDATA-RD61-
ListDetails-20081125120409_log.LDF')  
 
Run Now: 'ARKSPDATA-RD61-ListDetails-RUNNOW-20081125120409' with data 
('ARKSPDATA-RD61-ListDetails-RUNNOW-20081125120409.mdf') and log ('ARKSPDATA-
RD61-ListDetails-RUNNOW-20081125120409_log.LDF').  
 
The above files are stored in the default SQL data folder in the SQL server (C:\Program 
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Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data) 

 
Database cleanup 
 
ARKSP does not delete the Quick Reports database. You must delete the database manually 
after uninstalling ARKSP application. 
 
ARKSP deletes the Power Reports database after generating the reports as specified by the 
user. You can also cleanup the ARKSP database corresponding to a task or a task history 
instance using the óRemove allô or óRemoveô or óCleanup Historyô options in ARKSP main 
application. 
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4.3. E-mail Settings 

 
ARKSP provides the option to e-mail the reports generated using Power Reports tasks. For e-
mailing reports, ARKSP requires SMTP Server, From E-mail Address, To E-mail Addresses 
(recipients separated by semicolon) and the e-mail report format. ARKSP maintains a single 
SMTP Server and a From E-mail Address for use by all Power Report tasks. You can specify a 
separate set of To e-mail addresses (recipients), e-mail report format, subject and body of the 
message for each Power Report task. 
  
You can set SMTP Server and From Address by clicking Tools -> E-mail settings menu in the 
ARKSP main application window, as shown below: 
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4.4. Directory Server Settings 

 
ARKSP uses Directory Server to retrieve Active Directory information like group membership and 
user information for certain reports. ARKSP expects a Global Catalog Server as input to Directory 
Server and an user credential to connect to the directory server. ARKSP will connect based on 
authentication mode and user credential to the specified Directory Server to retrieve AD 
information.  
 
Directory Server Settings dialog in ARKSP appears as shown below: 
 

 
 
You can specify Directory Server Settings to use by clicking Tools -> Directory Server Settings 
menu in the ARKSP main application window, as shown below: 
 

 
 
To connect to Directory Server, ARKSP uses the relevant user accounts based on the connect 
option as listed below:  
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A. Currently logged on user: 
 
In this method, ARKSP uses the currently logged on user account to connect to the Directory 
Server to retrieve AD information while running Quick Reports (under interactive mode) and uses 
'Run As' account while running Power Reports task (run as a scheduled task or using Run Now 
option).  
 
B. Specific user account: 
 
In this method, ARKSP uses the specified user account and password to retrieve AD information 
while running Quick Reports and Power Reports tasks. ARKSP stores the user name and 
password as a user profile in 'Stored User Names and Passwords' applet for its usage.  
 
Read Profile Manager for more details. 
 

 

 Note: ARKSP expects the user account to have sufficient privileges to connect to the Active 
Directory Global Catalog Server, bind to the relevant AD group / user object to retrieve its detailed 
information from Active Directory. 
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4.5. IIS Log Files Directory 

 
ARKSP requires IIS Log Files Directory to be configured to generate reports such as List Visits, 
Last Deleted Items (Library only) under List category reports and Page Visits under Web 
Application category reports.  
  
1. You can set IIS Log Files Directory by clicking Tools -> IIS Log Files Directory menu in the 

ARKSP main application window, as shown below: 

 

 
 
2. In the IIS Log Files Directory dialog, all the Front-end web servers in the server farm will be 

loaded in the dropdown. 
 
3. Select or enter a Front-end web server name from the dropdown. 
 
4. For the selected server, enter IIS log directory in local file system (ex: 

C:\inetpub\logs\LogFiles) or UNC format (\\rd82\logs\LogFiles). 
 
5. Click Add button to add the server and log directory to the grid. 
 
6. Click Remove button to remove the server and its log directory from the grid. 
 
7. During report generation, IIS log files from the configured directories will be processed to 

generate report for the entire farm. 
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4.6. Audit Settings Manager 

 

 
Click 'Audit Settings Manager' button in the Tools menu. Audit Settings Manager dialog will be 
displayed as shown below: 
 

 
 
To add the site collection URL, 

1. Enter a valid site collection URL and click Add (or) Click 'Browse...' button to choose 
URL(s). This will display a window as shown below: 



Admin Report Kit for SharePoint 2007                                                                    

User Manual  Page 30 

 

 

To remove a site collection URL, select the URL from the URL list box and Click Remove button 
to remove the selected URL. 
 
Click OK button to configure the audit events for the selected site collection URL(s). 
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c) Profile Manager 

 
ARKSP creates a user profile in Windows Stored User Names and Passwords applet, in order 
to store the SQL and Directory Server user context for report generation using Quick Reports and 
Power Reports feature. 
 
The stored user profile will be useful for generating reports using ARKSP under the following 
scenarios: 
 

o Using an SQL Server having a dedicated SQL user account for report generation using 
ARKSP (highly recommended)  

o Using an SQL Server where SQL authentication mode is enabled  
o Using an SQL Server that is not part of the SharePoint domain  
o Using an alternate user account (other than currently logged on user) to connect to the 

Directory Server to retrieve AD information 
 
The stored user profile persists for all subsequent logon sessions on the same computer where 
ARKSP is installed. The stored user profiles are visible to the application under other logon 
sessions on the same computer. 
 
The stored user profile created by ARKSP is restricted to the Windows User Profile context. If the 
Windows User Profile is maintained locally, ARKSP stored user profile is accessible only by the 
same user in the same computer. If the user who creates ARKSP stored user profile, has a 
Roaming user account in the enterprise, the ARKSP stored user profile can be accessed by the 
same user in any computer in the Windows enterprise. 
 
The stored user profile is a generic credential of Windows Stored User Names and Passwords 
applet and can be used by ARKSP application only. The credential information is stored securely 
in an 256 bit encrypted format in Windows Stored User Names and Passwords applet. 
 
The stored user profile corresponding to the SQL user account will be used by ARKSP 
application in order to connect to the SQL Server, if SQL authentication is enabled in ARKSP 
SQL settings. 
 
The stored user profile corresponding to the Directory Server user account will be used by 
ARKSP application in order to connect to the Directory Server, if connect using option is enabled 
in ARKSP Directory Server settings. 
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d) Task Status 

 

To view and manage task status of a selected task: 

1. Select Tools > Show Task Status from the main window or Click from 
Power Reports Actions Pane.  
 

2. The Task Status dialog appears as shown below : 

 
 
You can perform the following actions in the Task Status dialog:  
 

a. Show status for <n> days: Upon clicking Go button, displays task history entries of all 
tasks that were run within the specified number of days. 

b. Refresh: Reloads the task history entries and updates the newly run tasks (if any). 

c. View log file: Displays activity log of the currently selected task history item. 

d. Remove: Removes the currently selected task history entry and its associated log folders 
and files. 

e. Remove all: Removes all task history entries and their associated log folders and files 
that are currently displayed. 

 
Click Close button to close this window. 
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e) Application Main Screen  

 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Tool Bar 

 
Report Menu  
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5) Built-in-Reports 

 

a) List of Web Application Reports 

 

 

Report Name Description Fields 

Content 
Databases 

Displays properties of the content 
databases in each web application 

Web Application, Database 
Name, Database Status, 
Database Server, Current 
Number of Sites, Site Level 
Warning, Maximum Number of 
Sites, Disk Size Required For 
Backup (in MB) 

Data Retrieval 
Settings 

Displays information about data retrieval 
settings such as data retrieval services, 
limit response size, data source timeout 
etc. 

Web Application, Inherit Central 
Administration Application 
Settings, Data Retrieval 
Services, Limit Response Size 
(in KB), Data Source Time-out 
(in seconds), Services Enabled, 
Update Support Enabled 

Page Visits Displays information about all the pages 
that are visited in the web application 

Web Application, Site URL, 
Page URL, User, Client IP 
Address, Visited Date 

Self Service Site 
Management 

Displays information about self service 
site creation settings for each web 
application 

Web Application, Self Service 
Site Creation Enabled, Require 
Secondary Contact 

Site Collection 
Administrators 

Displays information about the site 
collection administrators configured for 
the site collections 

Web Application, Site Collection 
URL , Created Date, Primary 
Administrator, Primary 
Administrator Login Name, 
Primary Administrator E-Mail, 
Secondary Administrator, 
Secondary Administrator Login 
Name, Secondary Administrator 
E-Mail 

Site Collection 
Features 

Displays information about activated 
features and its dependency details in 
site collections  

Web Application, Site URL, 
Feature Name, Feature Folder 
Name, Description, Action 
Dependency Feature, Hidden 

Site Collection 
Quotas and Locks 

Displays information about the site 
collection storage settings and lock 
settings 

Web Application, Site URL, 
Owner Login Name, Quota 
Template, Storage Maximum 
Level (in MB), Current Storage 
Used (in MB), Storage Warning 
Level (in MB), Read Locked, 
Write Locked 

Site Collection 
Summary 

Displays site collection information such 
as site URL, owner name, email etc. 

Web Application, Site URL, 
Created Date, Last Item 
Modified Date, Last Content 
Modified Date, Last Security 
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Modified Date, Primary Owner 
Name, Primary Owner Display 
Name, Primary Owner E-Mail, 
Secondary Owner Name, 
Secondary Owner Display 
Name, Secondary Owner E-
Mail, Number of Sub webs, 
Number of Users, Number of 
Groups, Number of Alerts 

Site Collection 
Workflow 
Templates 

Displays information about the workflow 
templates configured in each site 
collection 

Web Application, Site URL, 
Workflow Template Name, 
Description, Associations, In 
Progress, Permissions 

Web Application 
E-Mail Settings 

Displays information about the e-mail 
settings for the web application 

Web Application, From Address, 
Reply To Address, Outbound 
SMTP Server 

Web Application 
Features 

Displays information about activated 
features and its dependency details for 
all web applications 

Web Application, Feature Name, 
Feature Folder Name, 
Description, Action Dependency 
Feature, Hidden 

Web Application 
General Settings 

Displays web application general 
settings information such as default time 
zone, default quota template, maximum 
number of alerts etc. 

Web Application, Default Time 
Zone, Default Quota Template, 
Presence Enabled, Maximum 
Upload Size (in MB), Alerts 
Enabled, Alerts Limited, 
Maximum Alerts, RSS Feeds 
Enabled, Blog API Enabled, 
Blog API Authentication 
Enabled, Security Validation 
Enabled, Security Validation 
Expires, Security Validation 
Timeout (in minutes), Send 
Login Credentials By E-Mail, 
Event Handlers Enabled, Delete 
Log Entries, Log Retention 
Period (in days), Recycle Bin 
Enabled, Recycle Bin Cleanup 
Enabled, Recycle Bin Retention 
Period (in days), Second Stage 
Recycle Bin Quota (in 
percentage) 

Web Application 
Summary 

Displays web application information 
such as application pool name, content 
database, version etc. 

Web Application, Version, Host 
Name, Port Number, Zone, 
Allow Anonymous, 
Authentication Mode, 
Authentication Provider, Use 
Secure Sockets Layer, 
Application Pool Name, 
Application Pool Status, Identity 
Type, User Name, Number of 
Content Databases, Content 
Databases 

Web Application 
Use Confirmation 
and Deletion 

Displays information about the 
confirmation and deletion settings for 
unused web site collections 

Web Application, Send Unused 
Site Collection E-Mail 
Notification, Send Notifications 
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After (in days), Unconfirmed Site 
Collection Deletion Enabled, 
Number of Notifications Before 
Deletion 

Web Application 
User Permissions  

Displays user permissions defined for 
each web application  

Web Application, User 
Permissions 

Web Part Pages 
Security  

Displays security information for web 
parts and web part pages in each web 
application  

Web Application, Allow Web 
Parts To Communicate, Allow 
Access To Web Part Catalog 
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b) List of Sites Reports 

 

 

Report Name Description Fields 
Alerts Displays information about all the 

alerts created for notifying the 
changes 

Web URL, Web Title, Alert Title, 
Alert Type, Alert Frequency, Alert 
Time 

Audit - Deleted 
Lists 

Audit report displays the deleted lists 
in each site in the last 'N' days 

Web URL, Web Title, List URL, 
Occurred, Performed By 

Audit - Deleted 
Sites  

Audit report displays the deleted sites 
in the last 'N days 

Web URL, Web Title, Site Name, 
Occurred, Performed By 

Audit - Group 
Created 

Audit report displays the groups 
created in each site in the last 'N' days 

Web URL, Web Title, Group Name, 
Occurred, Performed By 

Audit - Group 
Deleted 

Audit report displays the group deleted 
in each site in the last 'N' days 

Web URL, Web Title, Group ID, 
Occurred, Performed By 

Audit - Group 
Member Added 

Audit report displays the list of newly 
added members in a Group in the last 
'N' days  

Web URL, Web Title, User Name, 
Group Name, Occurred, Performed 
By 

Audit - Group 
Member Deleted 

Audit report displays the list of deleted 
members from a Group in the last 'N' 
days 

Web URL, Web Title, User Name, 
Group Name, Occurred, Performed 
By 

Audit - Page 
Visits  

Audit report displays the web pages 
visited in each site in the last 'N' days 

Web URL, Web Title, Page URL, 
Occurred, Performed By 

Audit - 
Permission 
Inheritance 
Changed 

Audit report displays permissions 
inheritance changes in sites, lists, 
folders and items in each site in the 
last 'N' days 

Web URL, Web Title, Event 
Name, URL ,Occurred, Performed 
By 

Audit - 
Permission 
Level Added 

Audit report displays permission levels 
added or created details in each site in 
the last 'N' days 

Web URL, Web Title, URL, 
Permission Level, Occurred, 
Performed By 

Audit - 
Permission 
Level Deleted 

Audit report displays permission levels 
that are deleted in each site in the last 
'N' days 

Web URL, Web Title, URL, 
Permission Level ID, Occurred, 
Performed By 

Audit - 
Permission 
Level Modified 

Audit report displays permission levels 
modified in each site in the last 'N' 
days 

Web URL, Web Title, URL, 
Permission Level, Occurred, 
Performed By 

Audit - 
Permissions 
Changed 

Audit report displays the permission 
changes performed in Groups/Users in 
each site in the last 'N' days 

Web URL, Web Title, URL, 
Groups/Users ,Occurred, Performed 
By 

Audit - Search Audit report displays the search 
queries and scope used in each site in 
the last 'N' days 

Web URL, Web Title, Query, Search 
Scope, Occurred, Performed By 

List Templates Displays information about all the list 
templates available in the site 

Web URL, Web Title, List Template, 
Internal Name, Description, 
Document Template, Type, Base 
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Type, Category Type, On Quick 
Launch, Is Custom Template 

Page Hits Displays the number of times a web 
page has been visited in each site 

Web URL, Web Title, File URL, Total 
Hits, Recent Month Hits, Recent 
Day, Recent Day Hits 

Recycle Bin 
Summary 

Displays recycle bin summary 
information like total number of items, 
last deleted date, total size of deleted 
item etc. 

Web URL, Web Title, Last Item 
Deleted Date, Last Item Deleted By, 
Total size (in MB) 

Site Columns Displays all the site columns that are 
available in the site 

Web URL, Web Title, Column Name, 
Type, Type Display Name, Group, 
Description, Required 

Site Content 
Types 

Displays all the site content types that 
are available in the site 

Web URL, Web Title, Content Type, 
Description, Group, Document 
Template, Document Template URL, 
Read Only 

Site Features Displays information about activated 
features and its dependency details in 
each site 

Web URL, Web Title, Feature Name, 
Feature Folder Name, Description, 
Action Dependency Feature, Hidden 

Site Hits 
Summary 

Displays a summary of site visits Web URL, Web Title, Total Hits, 
Recent Month Hits, Recent Day, 
Recent Day Hits 

Site People and 
Groups 

Displays information about people and 
groups available in each site 

Web URL, Web Title, Groups/Users, 
Account Type, View Membership, 
Edit Membership, Join/Leave Group, 
Auto Accept, Member Of, 
Permission Levels 

Site Permission 
Levels 

Displays information about permission 
levels defined in each site 

Web URL, Web Title, Permission 
Level, Description, Permissions 

Site Permissions Displays information about site 
permissions (groups and users) 
defined in each site 

Web URL, Web Title, Group/Users , 
Account Type, Description, Group 
Owner, Permissions, Members 

Site Visitors Displays the number of times users 
have visited each site. 

Web URL, Web Title, User, Total 
Hits, Recent Month Hits, Recent 
Day, Recent Day Hits 

Site Security Displays site security information like 
allow anonymous access, 
authentication mode etc. 

Web URL, Web Title, Allow 
Anonymous Access, Anonymous 
State, Allow Unsafe Updates, 
Authentication Mode, Has External 
Security Provider, Inherits Role 
Assignments, Inherits Role 
Definitions, Request Access 
Enabled, Request Access E-Mail 

Site Settings Displays site settings information like 
time zone, theme, template etc. 

Web URL, Web Title, Description, 
Time Zone, Theme, Template, Quick 
Launch Enabled, Tree View 
Enabled, RSS Enabled 

Site Summary Displays site summary information like 
author, created date, number of sub 
webs etc. 

Web URL, Web Title, Author, 
Created Date, Last Item Modified 
Date, Web Size (in MB), Number of 
Sub webs, Number of Users, 
Number of Groups, Number of Lists, 
Number of Alerts, Number of 
Content Types, Number of Site 
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Columns 
Web Pages Displays information about all the web 

pages that are available in each site 
Web URL, Web Title, Web Page 
Title, Web Page URL, Author, Web 
Part Title, Created On, Last 
Modified, Page Size (in KB), Total 
Size (in KB) 

Web Parts Displays information all the web parts 
available in each site, user who 
created the web part etc. 

Web URL, Web Title, Web Part Title, 
Web Part Name, Parent Folder, 
Author, Created On, Last Modified, 
Size (in KB) 

Web Parts 
Utilization 

Displays information about utilization 
(size, used web pages, etc) of all the 
web parts in the site's web part gallery 

Web URL, Web Title, Web Part Title, 
Web Part Name, Web Page Title, 
Web Page URL, Parent Folder, 
Author, Created On, Last Modified, 
Size (in KB) 
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c) List of List Reports 

 
 
Report Name Description Report Fields 

Audit ï Checked-In 
Items 

Audit report displays the list items 
checked-in in the last 'N' days 

Web URL, Web Title, List Name, 
Item URL, Occurred, Performed By 

Audit ï Checked-Out 
Items 

Audit report displays the list items 
checked-out in the last 'N' days 

Web URL, Web Title, List Name, 
Item URL, Occurred, Performed By 

Audit ï Copied Items Audit report displays the list items 
that are copied to another location 
in the last 'N' days 

Web URL, Web Title, List Name, 
Source URL, Destination URL, 
Occurred, Performed By 

Audit ï Deleted 
Items 

Audit report displays the list items 
deleted in the last 'N' days 

Web URL, Web Title, List Name, 
Item URL, Occurred, Performed By 

Audit ï Profile 
Changed 

Audit report displays the changes 
details about the content types in 
the connected list in the last 'N' 
days 

Web URL, Web Title, List Name, 
Content Type Name, Group Name, 
Performed On, Performed By 

Audit ï Renamed 
Items 

Audit report displays the list items 
that are renamed in the last 'N' 
days 

Web URL, Web Title, List Name, 
Old Name, New Name, Occurred, 
Performed By 

Audit ï Restored 
Items 

Audit report displays the list of 
items that are restored from the 
Recycle Bin in the last 'N' days 

Web URL, Web Title, List Name, 
Item URL, Occurred, Performed By 

Audit ï Updated 
Items 

Audit report displays the list items 
added or modified in the last 'N' 
days 

Web URL, Web Title, List Name, 
Item URL, Occurred, Performed By 

Audit ï Visited Items Audit report displays the list items 
visited in the last 'N' days 

Web URL, Web Title, List Name, 
Item URL, Occurred, Performed By 

Checked Out 
Documents (Library 
only) 

Displays the list of documents that 
are checked out in a library 

Web URL, Web Title, Item URL, 
Created By, Created Date, Size (in 
MB), Checked Out By, Checked 
Out Date, Check Out Status 

File Types Displays the file types available in 
the document library 

Web URL, Web Title, Base 
Template, List Name, File Type, 
Count 

Last Deleted Items 
(Library only) 

Displays the list of items that are 
deleted in last 'N' days 

Item URL, Deleted By, Deleted 
Date 

Last Modified Items Displays the list of items that are 
modified in last 'N' days 

Web URL, Web Title, Item URL, 
Modified By, Modified Date, Size (in 
MB) 

List Columns Displays all the columns available 
in the list 

Web URL, Web Title, Base 
Template, List Name, Column 
Name, Type, Description, Required  

List Folders Security Displays information about the 
Groups/Users and their 
permissions assigned to each 
folder and its sub-folders in the 

Web URL, Web Title, Base 
Template, List Name, Folder Name, 
Folder URL, Groups/Users, 
Permissions 
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connected list. 

List General Settings Displays general settings 
information about the list such as 
versioning enabled, version limit, 
etc. 

Web URL, Web Title, Base 
Template, List Name, Description, 
Attachments  Enabled, On Quick 
Launch Bar, Permission 
Inheritance, Versioning Enabled, 
Minor Versions Enabled, Folder 
Creation Enabled, RSS Enabled, 
Major Version Limit, Major With 
Minor Version Limit, Unique Role 
Assignments, Force Check Out, 
Allow Content Types, Allow 
Everyone To View Items 

List Hits Displays the information 
about number of times a list has 
been visited in the last 'N' days 

Web URL, Web Title, List Name, 
Total Hits, Recent Month Hits, Last 
Accessed Day, Last Accessed Day 
Hits 

List Item Security Displays information about the 
users and their permissions 
assigned to each list item 

Web URL, Web Title, Base 
Template, List Name, Item URL, 
Item Title, Groups/Users, 
Permissions 

List Item Summary Displays summary information 
about the list such as created by, 
created date, etc. 

Web URL, Web Title, Base 
Template, List Name, Item URL, 
Item Title, Created By, Created 
Date, Modified By, Modified Date 

List Permissions Displays information about list 
permissions defined for each user / 
group 

Web URL, Web Title, Base 
Template, List Name, 
Groups/Users, Permissions 

List Summary Displays summary information 
about the list such as size, number 
of users, number of columns, etc. 

Web URL, Web Title, List Name, 
Base Template, Number of 
Columns, Number of Users, 
Number of Folders, Number of 
Items, List Size (in MB), Author, 
Created Date, Last Modified Date, 
Last Deleted Date 

List Views Displays all the views available for 
the list 

Web URL, Web Title, Base 
Template, List Name, View Name, 
View Type, Default View 

List Visits Displays information about the list 
items that are accessed in last 'N' 
days 

Item URL, Item ID, Total Visit 
Count, Item Title, Item Visit URL, 
Visit Count, Action, Visited By, 
Visited Date, Visited Time 

List Workflow 
Settings 

Displays information about 
workflow details in the list 

Web URL, Web Title, Base 
Template, List Name, Workflow 
Template, Workflow Name, 
Description, Created Date, Modified 
Date, Task List, History List, Allow 
Manual Start, Auto Start Workflow 
On Item Creation, Auto Start 
Workflow On Item Change, 
Permissions 

List Workflow Status 
- Canceled 

Displays workflow task details for 
each list item in the list, whose 
workflow status is 'Canceled' 

Web URL, Web Title, Base 
Template, List Name, Item URL, 
Item Title, Workflow Name, Initiator, 
Started On, Last Run, Task Title, 
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Task Assigned To, Due Date, Task 
Status, Outcome 

List Workflow Status 
- Completed 

Displays workflow task details for 
each list item in the list, whose 
workflow status is 'Completed' 

Web URL, Web Title, Base 
Template, List Name, Item URL, 
Item Title, Workflow Name, Initiator, 
Started On, Last Run, Task Title, 
Task Assigned To, Due Date, Task 
Status, Outcome 

List Workflow Status 
- Error Occurred 

Displays workflow task details for 
each list item in the list, whose 
workflow status is 'Error Occurred' 

Web URL, Web Title, Base 
Template, List Name, Item URL, 
Item Title, Workflow Name, Initiator, 
Started On, Last Run, Task Title, 
Task Assigned To, Due Date, Task 
Status, Outcome 

List Workflow Status 
- Failed 

Displays workflow task details for 
each list item in the list, whose 
workflow status is 'Failed' 

Web URL, Web Title, Base 
Template, List Name, Item URL, 
Item Title, Workflow Name, Initiator, 
Started On, Last Run, Task Title, 
Task Assigned To, Due Date, Task 
Status, Outcome 

List Workflow Status 
- In Progress 

Displays workflow task details for 
each list item in the list, whose 
workflow status is 'In Progress' 

Web URL, Web Title, Base 
Template, List Name, Item URL, 
Item Title, Workflow Name, Initiator, 
Started On, Last Run, Task Title, 
Task Assigned To, Due Date, Task 
Status, Outcome 

List Workflow Status 
- Not Started 

Displays workflow task details for 
each list item in the list, whose 
workflow status is 'Not Started' 

Web URL, Web Title, Base 
Template, List Name, Item URL, 
Item Title, Workflow Name, Initiator, 
Started On, Last Run, Task Title, 
Task Assigned To, Due Date, Task 
Status, Outcome 

Newly Added Items Displays the list of items that are 
created in last 'N' days 

Web URL, Web Title, Item URL, 
Created By, Created Date, Size (in 
MB) 

Version History 
(Library only) 

Displays information about all the 
versions available for each file in 
the document library 

Document URL, Latest Version, 
Number of Versions, Version ID, 
Created By, Created Date, Modified 
By, Modified Date, Size (in MB) 
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d) Usage Analysis Reports 

 

Usage analysis reports display detailed information about usage of Sites and Lists in a 
SharePoint server. ARKSP gathers usage information from STS and IIS log files to present the 
reports to the user. Please read the information given below to view the reports that are based on 
log files.  

ARKSP collects information from STS log files for the reports stated below. These reports 
require STS logging to be enabled to generate the report. Enable the "Enable Logging" and 
"Enable usage analysis processing" options in the "Usage Analysis Processing" section in 
SharePoint Central Administration. Click here to view detailed information about how to enable 
STS logging in SharePoint. 

Report Category Report Name Description 

Site Page Hits Displays the number of times a web page has 
been visited in each site. 

Site Site Visitors Displays the number of times users have visited 
each site. 

Site Site Hits Summary  Displays a summary of site visits. 

List List Hits Displays the information about number of times a 
list has been visited in the last 'N' days 

ARKSP collects information from IIS log files for the reports stated below. These reports require 
IIS logging to be enabled to generate the report. Enable the "Enable Logging" option in IIS for the 
web application. Click here to view detailed information about how to enable IIS logging. 

Report Category Report Name Description 

Web Application Page Visits Displays information about all the pages that are 
visited in the web application.  

List List Visits Displays information about the list items that are 
accessed in last 'N' days 

List Last Deleted Items  Displays the list of items that are deleted in last 'N' 
days 

The above mentioned IIS log files based reports require IIS Log Files Directory to be configured 
to process IIS log file data and generate the reports successfully. To configure, Go to Tools-> IIS 
Log Files Directory. 

Note: If you are running ARKSP on Windows Server 2008, please ensure 'ODBC Logging' is 
installed on the server to generate the above mentioned IIS reports successfully. 

 

 

 

http://support.microsoft.com/kb/825541
http://support.microsoft.com/kb/313437
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Steps to verify whether 'ODBC Logging' is installed on the server:  

1) In ARKSP installed server, click Start, point to Administrative Tools, and then click Server 
Manager.  

2) In the Server Manager hierarchy pane, expand Roles, and then click Web Server (IIS).  

3) In the Web Server (IIS) pane, scroll to the Role Services section.  

4) On the Role Services page, ensure ODBC Logging (available under Health and Diagnostics 
node) is checked.  

5) On the Role Services page, click Cancel. 

If 'ODBC Logging' is not installed on the server, please perform the steps to install it on the 
server:  

1) In ARKSP installed server, click Start, point to Administrative Tools, and then click Server 
Manager.  

2) In the Server Manager hierarchy pane, expand Roles, and then click Web Server (IIS).  

3) In the Web Server (IIS) pane, scroll to the Role Services section, and then click Add Role 
Services.  

4) On the Select Role Services page of the Add Role Services Wizard, select ODBC Logging 
(available under Health and Diagnostics node).  

5) On the Select Role Services page, click Next.  

6) On the Confirm Installation Selections page, click Install.  

7) On the Results page, click Close. 
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e) Audit Reports 

 
ARKSP provides Audit Reports across Site Collections and Lists. You have to enable audit 
settings in MOSS / WSS to view the reports in ARKSP. Please follow the instructions given below 
to enable the audit settings.  

a) How to configure audit settings in Microsoft Office SharePoint Server 2007 (MOSS)?  

Click here to view the detailed information about how to configure audit settings in MOSS. You 
can also configure audit settings in MOSS using 'Audit Settings Manager' in ARKSP. Click here to 
view the detailed information. 

b) How to configure audit settings in Windows SharePoint Services 3.0 (WSS)? 

WSS does not provide an user interface to configure the audit settings. You can configure audit 
settings in WSS 3.0 using 'Audit Settings Manager' in ARKSP. Click here to view the detailed 
information.  

  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

http://office.microsoft.com/en-us/sharepointserver/HA100997261033.aspx?pid=CH101237681033
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6) Quick Reports 

 

a) Web Application Reports 

 
Web application reports deal with providing information about the web application configured in 
SharePoint server. 
 
Click File -> Quick Reports to invoke ARKSP Quick Reports Wizard. 
 

 
 
Perform the following steps to run a quick report under the Web Application category: 
 
Select a report and click Next button (when a report scope is applicable, otherwise click the 
Finish button). This will display a window as shown below: 
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Choose a report scope: 
 

a) 'All web applications' - Collects the report data for all web applications configured in 
SharePoint  

b) 'Connected web application only' - Collects report data for the specified web applications 
only. 

 

Type a valid 'Web Application URL or Click  button to choose a web application. 
 
Click Finish button to view the selected report. 
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a) Site Reports 

 
Site Reports provide useful configuration and usage information about the connected site. 
ARKSP provides not only currently connected site information, but also its sub-sites. 
 
Click File ->Quick Reports to invoke ARKSP Quick Reports Wizard. 
 

 
 
Select any desired report and Click Next button to continue. This will display a window as shown 
below: 
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Select any of the following scope for the report to be viewed: 

a) All sites in web application - If URL entered is a valid Web Application URL, ARKSP 
retrieves report information for all the sites, including sub-sites and  top level sites, in the 
web application 

b) Connected site and its sub-sites - Retrieves report information for the connected site 
and its sub-sites  

c) Connected site only - Retrieves report information for the connected site only.  

 
By default, All sites in web application option will be selected 
 
To connect to a particular site:   

a) Type full URL of the site in the format http://servername:port number/sitename (or)  

b) Click  button to show the Select a SharePoint Site dialog as shown below. 
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Select the required site and Click OK button. 
 
Click Finish button in the wizard to view the report. 
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b) View List Reports 

 
List report shows detailed information about all the list types such as document library, picture 
library, contacts etc., and This report provides configuration information, users, columns, and 
views information based on the scope and URL specified. 
 
 
For the Document Library, Picture Library, Form Library, ARKSP reports size of the list, number 
of folders and files, top folders and files in the list, file types present in the list such as DOC, XLS, 
HTML, PPT etc. 
 
Click File ->Quick Reports to invoke ARKSP Quick Reports Wizard. 
 

 
 
Select any desired report and click Next to continue. This will display a window as shown below: 
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Select any of the following scopes for the report to be viewed:  

a. All lists in the connected site and its sub-sites - If URL entered is a valid site URL, 
ARKSP retrieves report information for all lists in the connected site and its sub-sites.  

b. All lists in the connected site - Retrieves report information for all the lists in the 
connected site.  

c. Connected list only - Retrieves report information for the connected list only.  

 

By default, All lists in the connected site and its sub-sites option will be selected. 

To connect to a particular site or list:   

a) Type full URL of the site in the format http://servername:port number/sitename or 
http://servername:port number/sitename/listname for the scope option selected.  (or)  

b) You can also Click  button to show the Select a SharePoint List or Select a 
SharePoint Site dialog as shown below. 


